<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://repeatingislands.com/xmlrpc.php">

<title>The Rock That Ended the Dinosaurs Was Much More Than a Dino Killer &#8211; Repeating Islands</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Gentium+Book+Basic:r:latin,latin-ext","Gentium+Book+Basic:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s0.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active body, .wf-active button, .wf-active input, .wf-active select, .wf-active textarea{font-family:"Gentium Book Basic",serif}.wf-active .site-description{font-family:"Gentium Book Basic",serif}.wf-active .page-links > .page-links-title{font-family:"Gentium Book Basic",serif}.wf-active .archive .taxonomy-description, .wf-active .search-results .page-title span{font-family:"Gentium Book Basic",serif}.wf-active .comment-reply-title small{font-family:"Gentium Book Basic",serif}.wf-active #comments #respond p.form-submit input#comment-submit{font-family:"Gentium Book Basic",serif}.wf-active h1, .wf-active h2:not(.site-description), .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6{font-family:"Gentium Book Basic",serif;font-weight:400;font-style:normal}.wf-active h1{font-size:3.6em;font-style:normal;font-weight:400}.wf-active h2:not(.site-description){font-size:3em;font-style:normal;font-weight:400}.wf-active h3{font-size:2.4em;font-style:normal;font-weight:400}.wf-active h4{font-size:2.2em;font-style:normal;font-weight:400}.wf-active h5{font-size:1.8em;font-style:normal;font-weight:400}.wf-active h6{font-size:1.6em;font-style:normal;font-weight:400}.wf-active .site-title{font-size:2.2em;font-weight:400;font-style:normal}.wf-active .menu-title{font-size:2.4em;font-weight:400;font-style:normal}.wf-active .widget-title, .wf-active .widgettitle{font-size:2.4em;font-weight:400;font-style:normal}.wf-active .entry-title, .wf-active .page-title{font-size:2.4em;font-weight:400;font-style:normal}.wf-active .entry-author .author-heading{font-size:1.6em;font-weight:400;font-style:normal}.wf-active .page-links{font-family:"Gentium Book Basic",serif;font-style:normal;font-weight:400}.wf-active .archive .page-title, .wf-active .search-results .page-title{font-size:1.6em;font-style:normal;font-weight:400}.wf-active .format-link .entry-title a:after{font-size:1.6em;font-style:normal;font-weight:400}.wf-active .comment-reply-title, .wf-active .comments-title{font-size:2.4em;font-weight:400;font-style:normal}.wf-active .comment #respond h3 small a, .wf-active .comment-reply-title a{font-weight:400;font-style:normal}.wf-active .comment-author{font-family:"Gentium Book Basic",serif;font-weight:400;font-style:normal}.wf-active .no-comments{font-family:"Gentium Book Basic",serif;font-size:2.4em;font-weight:400;font-style:normal}.wf-active .hentry div#jp-relatedposts h3.jp-relatedposts-headline, .wf-active .hentry div.sharedaddy h3.sd-title{font-family:"Gentium Book Basic",serif;font-size:1.6em;font-weight:400;font-style:normal}.wf-active .widget_jetpack_display_posts_widget .jetpack-display-remote-posts h4{font-size:1.8em;font-style:normal;font-weight:400}.wf-active .widget-grofile .widget-title{font-size:2.74285712em;font-style:normal;font-weight:400}.wf-active .widget-grofile h4{font-size:1.8285712em;font-style:normal;font-weight:400}.wf-active .widget_goodreads h2[class^="gr_custom_header"]{font-size:1.8em;font-style:normal;font-weight:400}.wf-active .widget.top_rated .pd_top_rated_holder_posts > p{font-family:"Gentium Book Basic",serif;font-style:normal;font-weight:400}@media screen and (max-width: 782px){.wf-active .page-title, .wf-active body.page .entry-title, .wf-active body.single .entry-title{font-size:3.6em;font-style:normal;font-weight:400}}</style>
<meta name='robots' content='max-image-preview:large' />

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//repeatingislands.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Repeating Islands &raquo; Feed" href="https://repeatingislands.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Repeating Islands &raquo; Comments Feed" href="https://repeatingislands.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Repeating Islands &raquo; The Rock That Ended the Dinosaurs Was Much More Than a Dino Killer Comments Feed" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1625065786h&ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyNkttuwyAMhl9ohJJu026mPQsHi7nlJAytePuRbKuytE13g/htf8Y25ufEdAwFQuG+suSqxUD8nHT0jDw6aCs1aKInfhvL4GQBw1KkslJbmMMjED9ASVIf2ayuwn9jbe1SQbbdk4GfhBieB8FVRWe4cnFOoLLMjVNpDi6JMGhXzfQOcQ8GJTjwcyELkZxskJkDK3UbPIbHePct9R/ofvFzpYueZYu1MJvRrMr+d4osCwZLD3Adf7BxELs+N4NULkZ2m1381DTzbvdJXje+gX0vkFIpAxHrp8fqWfns4OZiWAiQsTvuXCf2w7+L1/3uRbyN4/7wBekZDw4=?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='boardwalk-source-code-pro-css'  href='https://fonts.googleapis.com/css?family=Source+Code+Pro%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=5.8.1' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJyNjEEOwiAQRS8kTqqxroxnATql6MAQBiTeXuqqbhp3/yX/PWhJWY4FY4GyYECBVA0Y1nlqmp7gowUpb0LVkuVwtCIH2EihqkTV+SjQ/OSwCBROKrH09RX3FKlGbPapeO40MxG3vf/CL8zKVGMI/8g7ZEVs9Zr/ATWT9nlPzWiIXZ8O+muDq3QPt+EynMdhPJ+ujw97LnnF?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link crossorigin="anonymous" rel='stylesheet' id='cubic-montserrat-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cubic-playfair-display-css'  href='https://fonts.googleapis.com/css?family=Playfair+Display%3A400%2C700%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' media='all' />
<link rel='stylesheet' id='all-css-8-1' href='https://s2.wp.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WLyhN0k/KTyxKKU/MydYvLqnMSdVLLi7W0ceuNLk0KTOZWGWZeVCluuUFyfm5IA32ubaGpsYG5ibmlhZmWQBcAjSK?cssminify=yes' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='all-css-10-1' href='https://s0.wp.com/_static/??-eJyNjs0OwjAMg1+IEAYMxAHxLF3btUFpUzWd9voMCQ78CHGyLfmzjHMBK7n53DBNUHgKlBWLaIORDVXUaCrl8NS1VV3hd0rFkmFgCfIaPqAWffKKcY+BZTD8a3UmF3xTXCoPD6GSA5MdMGn7hx2WGwoEozDL/BbvA5d07g677rjtT/3megMbGmbb?cssminify=yes' type='text/css' media='all' />
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"6765016","siteName":"Repeating Islands","siteURL":"https:\/\/repeatingislands.com","siteHost":"repeatingislands.com","icon":"<img alt='' src='https:\/\/repeatingislands.files.wordpress.com\/2020\/05\/cropped-gesner-abelard.jpg?w=50' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/cubic","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Frepeatingislands.com%252F2021%252F09%252F19%252Fthe-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer%252F","themeURL":"https:\/\/wordpress.com\/theme\/cubic\/","xhrURL":"https:\/\/repeatingislands.com\/wp-admin\/admin-ajax.php","nonce":"1569becc93","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"eafdae1499\" \/>","referer":"https:\/\/repeatingislands.com\/2021\/09\/19\/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer\/","canFollow":"1","feedID":"50129","statusMessage":"","subsEmailDefault":"instantly","customizeLink":"https:\/\/repeatingislands.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Frepeatingislands.wordpress.com%2F2021%2F09%2F19%2Fthe-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer%2F","postID":"169159","shortlink":"https:\/\/wp.me\/psnTa-I0n","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/repeatingislands.com\/169159","statsLink":"https:\/\/wordpress.com\/stats\/post\/169159\/repeatingislands.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Cubic","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 8,028 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Frepeatingislands.com%252F2021%252F09%252F19%252Fthe-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer%252F\">Log in now.<\/a>","stats":"Stats","notifyNewPosts":"Notify me of new posts","notifyNewPostsDetails":"Receive web and mobile notifications for new posts from this site.","emailNewPosts":"Email me new posts","emailNewPostsDetails":"You can customize your notification settings further <a href=\"https:\/\/wordpress.com\/following\/manage?s=repeatingislands.com\">here<\/a>.","emailNewComments":"Email me new comments","instantly":"Instantly","daily":"Daily","weekly":"Weekly"}};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??-eJyFjksOwjAMRC+ECREqrBBn6ceNHCVxiBNKb0/LRypdlJU9mjejUUOElkPGkJUVFVmyR5Ha4N7KTv26nhtyCEUwTUDIQKHnNecLRFcMBVEJXZ2xg7l1pb4pCq0rHcpcb28F0/g5e0/hLwSeTJpKl/Bib3IZYuLHuLFRSiNtopiJJ9Wzczxs4AN1BvNryfuFpvgId8I5dfUXfTrq86HSurJPyvqCIA=='></script>
<script type='text/javascript'>
	window.addEventListener( 'DOMContentLoaded', function() {
		rltInitialize( {"token":null,"iframeOrigins":["https:\/\/widgets.wp.com"]} );
	} );
</script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1625210320h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://repeatingislands.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/" />
<link rel='shortlink' href='https://wp.me/psnTa-I0n' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Frepeatingislands.com%2F2021%2F09%2F19%2Fthe-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Frepeatingislands.com%2F2021%2F09%2F19%2Fthe-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The Rock That Ended the Dinosaurs Was Much More Than a Dino Killer" />
<meta property="og:url" content="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/" />
<meta property="og:description" content="Well, since the Chicxulub impactor that killed the dinosaurs fell on the Caribbean region, I thought this may be on interest. Lisa In seeking the origin story of the Chicxulub impactor, scientists …" />
<meta property="article:published_time" content="2021-09-20T01:27:41+00:00" />
<meta property="article:modified_time" content="2021-09-20T01:27:41+00:00" />
<meta property="og:site_name" content="Repeating Islands" />
<meta property="og:image" content="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png" />
<meta property="og:image:width" content="922" />
<meta property="og:image:height" content="830" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@RepeatingIslands" />
<meta name="twitter:site" content="@RepeatingIslands" />
<meta name="twitter:text:title" content="The Rock That Ended the Dinosaurs Was Much More Than a Dino Killer" />
<meta name="twitter:image" content="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel='openid.server' href='https://repeatingislands.com/?openidserver=1' />
<link rel='openid.delegate' href='https://repeatingislands.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://repeatingislands.com/osd.xml" title="Repeating Islands" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="Repeating Islands" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="News and commentary on Caribbean culture, literature, and the arts" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://repeatingislands.com/feed/;icon-uri=https://repeatingislands.files.wordpress.com/2020/05/cropped-gesner-abelard.jpg?w=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Well, since the Chicxulub impactor that killed the dinosaurs fell on the Caribbean region, I thought this may be on interest. Lisa In seeking the origin story of the Chicxulub impactor, scientists hope to also unlock secrets about the origin of life itself. A report by Becky Ferreira for The New York Times. The first cave&hellip;" />
<link rel="amphtml" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/amp/"><style type="text/css" id="custom-colors-css">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</style>
<link rel="icon" href="https://repeatingislands.files.wordpress.com/2020/05/cropped-gesner-abelard.jpg?w=32" sizes="32x32" />
<link rel="icon" href="https://repeatingislands.files.wordpress.com/2020/05/cropped-gesner-abelard.jpg?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://repeatingislands.files.wordpress.com/2020/05/cropped-gesner-abelard.jpg?w=180" />
<meta name="msapplication-TileImage" content="https://repeatingislands.files.wordpress.com/2020/05/cropped-gesner-abelard.jpg?w=270" />
<!-- Your Google Analytics Plugin is missing the tracking ID -->
</head>

<body class="post-template-default single single-post postid-169159 single-format-standard wp-custom-logo customizer-styles-applied group-blog has-sidebar widgets-hidden has-site-logo highlander-enabled highlander-light custom-colors">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
		<div class="site-branding">
			<a href="https://repeatingislands.com/" class="site-logo-link" rel="home" itemprop="url"><img width="166" height="96" src="https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg?w=166" class="site-logo attachment-boardwalk-logo" alt="" loading="lazy" data-size="boardwalk-logo" itemprop="logo" srcset="https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg?w=166 166w, https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg?w=332 332w, https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg?w=150 150w, https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg?w=300 300w" sizes="(max-width: 166px) 100vw, 166px" data-attachment-id="155471" data-permalink="https://repeatingislands.com/large-1-3/" data-orig-file="https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg" data-orig-size="640,371" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1588728825&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="large-1 3" data-image-description="" data-image-caption="" data-medium-file="https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg?w=300" data-large-file="https://repeatingislands.files.wordpress.com/2020/05/large-1-3.jpg?w=640" /></a>			<div class="clear">
				<h1 class="site-title"><a href="https://repeatingislands.com/" rel="home">Repeating Islands</a></h1>
				<h2 class="site-description">News and commentary on Caribbean culture, literature, and the arts</h2>
			</div>
		</div><!-- .site-branding -->
					<button class="sidebar-toggle" aria-expanded="false" ><span class="screen-reader-text">Toggle Sidebar</span></button>
			</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-169159" class="post-169159 post type-post status-publish format-standard hentry category-news">
	
	<header class="entry-header">
		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published updated" datetime="2021-09-19T21:27:41-04:00">September 19, 2021</time></span>		</div><!-- .entry-meta -->
		<h1 class="entry-title">The Rock That Ended the Dinosaurs Was Much More Than a Dino Killer</h1>	</header><!-- .entry-header -->

	<div class="entry-content">
		
<figure class="wp-block-image size-large"><a href="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png"><img data-attachment-id="169165" data-permalink="https://repeatingislands.com/screenshot-2021-09-19-at-9-22-14-pm/" data-orig-file="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png" data-orig-size="922,830" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="screenshot-2021-09-19-at-9.22.14-pm" data-image-description="" data-image-caption="" data-medium-file="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png?w=300" data-large-file="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png?w=768" src="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png?w=922" alt="" class="wp-image-169165" srcset="https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png 922w, https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png?w=150 150w, https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png?w=300 300w, https://repeatingislands.files.wordpress.com/2021/09/screenshot-2021-09-19-at-9.22.14-pm.png?w=768 768w" sizes="(max-width: 922px) 100vw, 922px" /></a></figure>



<p>Well, since the Chicxulub impactor that killed the dinosaurs fell on the Caribbean region, I thought this may be on interest. Lisa</p>



<p id="article-summary">In seeking the origin story of the Chicxulub impactor, scientists hope to also unlock secrets about the origin of life itself.</p>



<p>A report by <a href="http://In seeking the origin story of the Chicxulub impactor, scientists hope to also unlock secrets about the origin of life itself.     153   Credit...Sally Deng By Becky Ferreira Sept. 13, 2021 The first cave art. The dawn of agriculture. While these are among the most crucial moments in humankind’s beginnings, our most dramatic origin story starts 66 million years ago. It was the apocalyptic instant when a rock from outer space slammed into Earth, terminating the age of dinosaurs and eventually offering a bountiful new world to our mammalian ancestors.  For 40 years, scientists have studied the tale of this catastrophic object, known now as the Chicxulub impactor. Today, the impactor represents more than just one bad day on Earth; instead, it has become a kind of Rosetta Stone that can decipher deeper riddles about the origins of life and the future of human civilization, both on our planet and in other worlds across the galaxy.  “The Chicxulub impact event completely modified the geologic and biologic evolution of planet Earth,” said David Kring, a planetary geologist who leads the Center for Lunar Science and Exploration in Houston and who was part of the team that announced the discovery of the Chicxulub impact crater beneath Mexico’s Yucatán Peninsula in 1991. “That is such a big scientific story with popular appeal because it extinguished dinosaurs and cleared the slate, if you will, for mammalian evolution that led to humans, it’s going to captivate both the scientific community and the public for years to come.”  For decades, scientists argued about the cause of the dinosaurs’ deaths. Volcanic eruptions and other exotic hypotheses were proposed, but the scientific consensus settled on a rock from space being the killer. The Chicxulub theory now reigns so supreme that scientists have pieced together detailed timelines of what transpired on that fateful day, and other researchers are writing what could be called the prequel, seeking the extraterrestrial origins of the event to which we partially owe our existence.  ADVERTISEMENT  Continue reading the main story  As more advanced tools and techniques become available, scientists have been able to extract new and precise insights about this epic wipeout on our planet, and what it may mean for the beginnings of life itself.  The latest find comes from a study published in July in the journal Icarus that sought the original home of the Chicxulub impactor. It did this by leveraging the immense processing power of a NASA supercomputer to model the motions of roughly 130,000 asteroids in the main belt between the orbits of Mars and Jupiter.  “Ultimately we want to solve big questions, and this kind of work allows us to get after some of them,” said Bill Bottke, a co-author of the study and director of the department of space studies at the Southwest Research Institute in Boulder, Colo.  The Icarus study is part of a constant stream of ideas about the impact that can be dazzling in their creativity, often to the point of controversy. Earlier this year, for instance, a Harvard University team revived the possibility that the impactor was a comet, sparking pushback from many scientists in the field.  Another scientist, Lisa Randall of Harvard University, even zoomed out to present a galactic view of the Chicxulub event. In her 2015 book “Dark Matter and the Dinosaurs,” Dr. Randall proposes that the Milky Way contains a layer of dark matter, a mysterious hypothetical substance, that can help nudge outer solar system comets toward Earth.  Editors’ Picks  Cedric the Entertainer Wants to Make the Emmys More Accessible  Hearing His Voice Changed Everything  ‘Muhammad Ali’ Explores the Many Layers of ‘the Greatest’ Continue reading the main story  ADVERTISEMENT  Continue reading the main story  Though this explanation has not gained a significant following, it demonstrates how Chicxulub attracts prismatic perspectives from the worlds of cosmology, computational science, astrobiology and other fields.  To that point, Dr. Bottke said that access to NASA’s Pleiades supercomputer was a “game changer” for his team, enabling the researchers to run simulations of a huge asteroid population over the course of hundreds of millions of years.  This Big Data technique helped to match the strong geological evidence that the impactor was a carbonaceous asteroid — and not a comet — with a possible origin in the outer asteroid belt. This distant region between Mars and Jupiter contains many miles-wide carbonaceous asteroids similar to the Chicxulub impactor. But these rocks aren’t gravitationally hoisted into collision courses with planets as frequently as asteroids in the inner region of the belt, where there are fewer objects that match Chicxulub’s composition.  “We were not finding an obvious solution to where one of the largest impactors that has hit Earth over recent time came from,” Dr. Bottke said. “Essentially, a lot of the possibilities we had tried just weren’t panning out. It was really frustrating and it seemed like we were missing something.”  The team’s supercomputer approach revealed that Chicxulub-like asteroids escape from the outer belt about 10 times more frequently than implied by previous models. That boosts the odds that the dinosaur-killing rock may have originated there.  “This is confirmation of a really cool idea, and I think it helps me understand a lot more about how the asteroid belt may be influencing the Earth over billions of years,” Dr. Bottke said.  Sean Gulick, a planetary geophysicist at the University of Texas at Austin who was one of the leaders of a 2016 scientific drilling expedition that obtained precious rock cores from the Chicxulub crater, said the paper was an interesting approach to performing “the forensics, if you will, about where the impactor came from. It’s intriguing because it was such an important event for the evolution of our planet and ourselves.”  ADVERTISEMENT  Continue reading the main story  Dr. Gulick also noted that the study highlighted the hazards that asteroids pose across time, including risks faced by our planet-bound civilization. The Chicxulub impact and the fate of the dinosaurs are frequently invoked as the ultimate argument both for investing in planetary defense research, and for expanding our species beyond Earth. (Although it’s worth noting that other worlds, including Mars, are not exempt from large-scale asteroid impacts.)  But Chicxulub also sheds light on some of the most evocative questions about the emergence of life. Dr. Kring has long been fascinated by this subject, and has helped produce a wealth of research about the microbial ecosystems that cropped up in the fallout of the apocalyptic event.  “There’s an argument that stipulates that this type of bombardment is involved in not only the perturbation of the evolution of life, but actually involved in the origin of life on our planet,” he said. “Understanding these processes is important, and our best measures of some of these consequences on Earth are going to come from the youngest of these impactors, like Chicxulub, because the evidence is more robust.”  The mission Dr. Gulick helped lead continues to clarify the impact’s role as both a destroyer and a crucible of life. As the researchers plumbed the depths of the buried Doomsday event, they found dusty traces of the impactor, sandy backwash from the tsunami it had created and the fossilized remains of organisms that thrived in its aftermath.  Perhaps most astonishing, a study published this summer described modern-day microbial descendants of those early crater adopters, still living in the shadow of the catastrophe that was colonized by their forebears.  “It’s amazing to me that you can have an impact and you can generate an ecosystem, then 66 million years later, you still have life that is present in that location because of this previous condition,” Dr. Gulick said. “On a bigger scale, maybe you can generate habitats with impacts really early in Earth’s history and have ecosystems survive afterward. That reflects one of the ways in which you might get life going.”  In this sense, the Chicxulub impactor truly does have galactic implications as a time capsule of both biological disaster and the birth of new life. Other life-bearing worlds across the Milky Way might be similarly shaped by asteroid impacts, with tales of destruction and recovery all their own.  “This is an issue that potentially goes far beyond the extinction of dinosaurs,” Dr. Kring said.">Becky Ferreira for <em>The New York Times</em></a>.</p>



<p>The first cave art. The dawn of agriculture. While these are among the most crucial moments in humankind’s beginnings, our most dramatic origin story starts 66 million years ago. It was the apocalyptic instant when a rock from outer space slammed into Earth, terminating the age of dinosaurs and eventually offering a bountiful new world to our mammalian ancestors.</p>



<p>For&nbsp;<a href="https://www.science.org/doi/abs/10.1126/science.208.4448.1095" rel="noreferrer noopener" target="_blank">40 years</a>, scientists have studied the tale of this catastrophic object, known now as the Chicxulub impactor. Today, the impactor represents more than just one bad day on Earth; instead, it has become a kind of Rosetta Stone that can decipher deeper riddles about the origins of life and the future of human civilization, both on our planet and in other worlds across the galaxy.</p>



<p>“The Chicxulub impact event completely modified the geologic and biologic evolution of planet Earth,” said David Kring, a planetary geologist who leads the Center for Lunar Science and Exploration in Houston and who was part of the team that&nbsp;<a href="https://pubs.geoscienceworld.org/gsa/geology/article-abstract/19/9/867/205322/Chicxulub-Crater-A-possible-Cretaceous-Tertiary" rel="noreferrer noopener" target="_blank">announced the discovery</a>&nbsp;of the Chicxulub impact crater beneath Mexico’s Yucatán Peninsula in 1991. “That is such a big scientific story with popular appeal because it extinguished dinosaurs and cleared the slate, if you will, for mammalian evolution that led to humans, it’s going to captivate both the scientific community and the public for years to come.”</p>



<p>For decades, scientists argued about the cause of the dinosaurs’ deaths. Volcanic eruptions and <a rel="noreferrer noopener" href="https://www.smithsonianmag.com/science-nature/the-top-ten-weirdest-dinosaur-extinction-ideas-23642539/" target="_blank">other exotic hypotheses</a> were proposed, but the scientific consensus settled on a rock from space being the killer. The Chicxulub theory now reigns so supreme that scientists have pieced together detailed timelines of what transpired on that fateful day, and other researchers are writing what could be called the prequel, seeking the extraterrestrial origins of the event to which we partially owe our existence.</p>



<p>As more advanced tools and techniques become available, scientists have been able to extract new and precise insights about this epic wipeout on our planet, and what it may mean for the beginnings of life itself.</p>



<p>The latest find comes from&nbsp;<a href="https://www.sciencedirect.com/science/article/abs/pii/S0019103521002840?via%3Dihub" rel="noreferrer noopener" target="_blank">a study published in July in the journal Icarus</a>&nbsp;that sought the original home of the Chicxulub impactor. It did this by leveraging the immense processing power of a NASA supercomputer to model the motions of roughly 130,000 asteroids in the main belt between the orbits of Mars and Jupiter.</p>



<p>“Ultimately we want to solve big questions, and this kind of work allows us to get after some of them,” said Bill Bottke, a co-author of the study and director of the department of space studies at the Southwest Research Institute in Boulder, Colo.</p>



<p>The Icarus study is part of a constant stream of ideas about the impact that can be dazzling in their creativity, often to the point of controversy. Earlier this year, for instance, a Harvard University team&nbsp;<a href="https://www.nytimes.com/2021/02/15/science/dinosaur-extinction-kt-comet-asteroid.html">revived the possibility</a>&nbsp;that the impactor was a comet,&nbsp;<a href="https://academic.oup.com/astrogeo/article/62/3/3.34/6275176" rel="noreferrer noopener" target="_blank">sparking pushback</a>&nbsp;from many scientists in the field.</p>



<p>Another scientist, Lisa Randall of Harvard University, even zoomed out to present a galactic view of the Chicxulub event. In <a href="https://www.nytimes.com/2015/11/29/books/review/dark-matter-and-the-dinosaurs-by-lisa-randall.html">her 2015 book “Dark Matter and the Dinosaurs,”</a> Dr. Randall proposes that the Milky Way contains a layer of dark matter, a mysterious hypothetical substance, that can help nudge outer solar system comets toward Earth.</p>



<p>Though this explanation has not gained a significant following, it demonstrates how Chicxulub attracts prismatic perspectives from the worlds of cosmology, computational science, astrobiology and other fields.</p>



<p>To that point, Dr. Bottke said that access to NASA’s Pleiades supercomputer was a “game changer” for his team, enabling the researchers to run simulations of a huge asteroid population over the course of hundreds of millions of years.</p>



<p>This Big Data technique helped to match the strong geological evidence that the impactor was a carbonaceous asteroid — and not a comet — with a possible origin in the outer asteroid belt. This distant region between Mars and Jupiter contains many miles-wide carbonaceous asteroids similar to the Chicxulub impactor. But these rocks aren’t gravitationally hoisted into collision courses with planets as frequently as asteroids in the inner region of the belt, where there are fewer objects that match Chicxulub’s composition.</p>



<p>“We were not finding an obvious solution to where one of the largest impactors that has hit Earth over recent time came from,” Dr. Bottke said. “Essentially, a lot of the possibilities we had tried just weren’t panning out. It was really frustrating and it seemed like we were missing something.”</p>



<p>The team’s supercomputer approach revealed that Chicxulub-like asteroids escape from the outer belt about 10 times more frequently than implied by previous models. That boosts the odds that the dinosaur-killing rock may have originated there.</p>



<p>“This is confirmation of a really cool idea, and I think it helps me understand a lot more about how the asteroid belt may be influencing the Earth over billions of years,” Dr. Bottke said.</p>



<p>Sean Gulick, a planetary geophysicist at the University of Texas at Austin who was one of the leaders of a 2016 scientific drilling expedition that obtained precious rock cores from the Chicxulub crater, said the paper was an interesting approach to performing “the forensics, if you will, about where the impactor came from. It’s intriguing because it was such an important event for the evolution of our planet and ourselves.”</p>



<p>Dr. Gulick also noted that the study highlighted the hazards that asteroids pose across time, including risks faced by our planet-bound civilization. The Chicxulub impact and the fate of the dinosaurs are frequently invoked as the ultimate argument both for investing in planetary defense research, and for expanding our species beyond Earth. (Although it’s worth noting that other worlds,&nbsp;<a href="https://www.nytimes.com/2019/07/30/science/mars-tsunami-crater.html">including Mars</a>, are not exempt from large-scale asteroid impacts.)</p>



<p>But Chicxulub also sheds light on some of the most evocative questions about the emergence of life. Dr. Kring has long been fascinated by this subject, and has helped produce&nbsp;<a href="https://newsroom.usra.edu/a-subterranean-ecosystem-in-the-chicxulub-crater/" rel="noreferrer noopener" target="_blank">a wealth of research about the microbial ecosystems</a>&nbsp;that cropped up in the fallout of the apocalyptic event.</p>



<p>“There’s an argument that stipulates that this type of bombardment is involved in not only the perturbation of the evolution of life, but actually involved in the origin of life on our planet,” he said. “Understanding these processes is important, and our best measures of some of these consequences on Earth are going to come from the youngest of these impactors, like Chicxulub, because the evidence is more robust.”</p>



<p>The mission Dr. Gulick helped lead continues to clarify the impact’s role as both a destroyer and a crucible of life. As the researchers plumbed the depths of the buried Doomsday event, they&nbsp;<a href="https://news.utexas.edu/2021/02/24/asteroid-dust-found-in-crater-closes-case-of-dinosaur-extinction/" rel="noreferrer noopener" target="_blank">found dusty traces</a>&nbsp;of the impactor,&nbsp;<a href="https://www.pnas.org/content/116/39/19342" rel="noreferrer noopener" target="_blank">sandy backwash from the tsunami</a>&nbsp;it had created and the&nbsp;<a href="https://www.nytimes.com/2020/02/01/science/asteroid-dinosaurs-crater-bacteria.html">fossilized remains</a>&nbsp;of organisms that thrived in its aftermath.</p>



<p>Perhaps most astonishing, a study&nbsp;<a href="https://www.frontiersin.org/articles/10.3389/fmicb.2021.668240/full" rel="noreferrer noopener" target="_blank">published this summer</a>&nbsp;described modern-day microbial descendants of those early crater adopters, still living in the shadow of the catastrophe that was colonized by their forebears.</p>



<p>“It’s amazing to me that you can have an impact and you can generate an ecosystem, then 66 million years later, you still have life that is present in that location because of this previous condition,” Dr. Gulick said. “On a bigger scale, maybe you can generate habitats with impacts really early in Earth’s history and have ecosystems survive afterward. That reflects one of the ways in which you might get life going.”</p>



<p>In this sense, the Chicxulub impactor truly does have galactic implications as a time capsule of both biological disaster and the birth of new life. Other life-bearing worlds across the Milky Way might be similarly shaped by asteroid impacts, with tales of destruction and recovery all their own.</p>



<p>“This is an issue that potentially goes far beyond the extinction of dinosaurs,” Dr. Kring said.</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-169159" class="share-facebook sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-169159" class="share-twitter sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-169159" class="share-linkedin sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-169159" class="share-pinterest sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-6765016-169159-6147fbb6d48ac' data-src='//widgets.wp.com/likes/index.html?ver=20210818#blog_id=6765016&amp;post_id=169159&amp;origin=repeatingislands.wordpress.com&amp;obj_id=6765016-169159-6147fbb6d48ac&amp;domain=repeatingislands.com' data-name='like-post-frame-6765016-169159-6147fbb6d48ac' data-title='Like or Reblog'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>			</div><!-- .entry-content -->

	
	<footer class="entry-footer">
		<span class="cat-links">Posted in <a href="https://repeatingislands.com/category/news/" rel="category tag">News</a></span><span class="byline">By <span class="author vcard"><a class="url fn n" href="https://repeatingislands.com/author/lisaparavisini/">lisaparavisini</a></span></span><span class="comments-link"><a href="https://repeatingislands.com/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/#respond">Leave a comment</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-## -->

			
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://repeatingislands.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="533dc39441" /><input type="hidden" name="_wp_http_referer" value="/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function () {

	function hide( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.setProperty( 'display', 'none' );
		}
	}

	function show( sel ) {
		var el = document.querySelector( sel );
		if ( el ) {
			el.style.removeProperty( 'display' );
		}
	}

	var input = document.createElement( 'input' );
	var comment = document.querySelector( '#comment' );

	if ( input && comment && 'placeholder' in input ) {
		var label = document.querySelector( '.comment-textarea label' );
		if ( label ) {
			var text = label.textContent;
			label.parentNode.removeChild( label );
			comment.setAttribute( 'placeholder', text );
		}
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	hide( '#comment-form-identity' );
	hide( '#comment-form-subscribe' );
	hide( '#commentform .form-submit' );

	if ( comment ) {
		comment.style.height = '10px';

		var handler = function () {
			comment.style.height = HighlanderComments.initialHeight + 'px';
			show( '#comment-form-identity' );
			show( '#comment-form-subscribe' );
			show( '#commentform .form-submit' );
			HighlanderComments.resizeCallback();

			comment.removeEventListener( 'focus', handler );
		};

		comment.addEventListener( 'focus', handler );
	}
}

if ( document.readyState !== 'loading' ) {
	highlander_expando_javascript();
} else {
	if ( typeof window.jQuery === 'function' ) {
		// Use jQuery's `ready` if available.
		// This solves some scheduling issues between this script and the main highlander script.
		jQuery( document ).ready( highlander_expando_javascript );
	} else {
		// If not available, add a vanilla event listener.
		document.addEventListener( 'DOMContentLoaded', highlander_expando_javascript );
	}
}

</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit wp-block-button"><input name="submit" type="submit" id="comment-submit" class="submit wp-block-button__link" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='169159' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="033a819b49" /></p>
<input type="hidden" name="genseq" value="1632107446" />
<input type="hidden" id="ak_js" name="ak_js" value="116"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

				<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">

			<div class="nav-previous"><a href="https://repeatingislands.com/2021/09/19/i-will-never-forget-that-i-could-have-lived-with-people-who-loved-me/" rel="prev"><span class="screen-reader-text"><span class="meta-nav">&larr;</span>&nbsp;I Will Never Forget That I Could Have Lived With People Who Loved Me</span></a></div><div class="nav-next"><a href="https://repeatingislands.com/2021/09/19/buena-vista-social-club-at-25-memories-of-memories/" rel="next"><span class="screen-reader-text">‘Buena Vista Social Club’ at 25: Memories of Memories&nbsp;<span class="meta-nav">&rarr;</span></span></a></div>
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	
		
		</main><!-- #main -->
	</div><!-- #primary -->


<div id="sidebar" class="sidebar" aria-hidden="true">
	<div class="sidebar-content">
		
				<div id="secondary" class="widget-area" role="complementary">
			<aside id="search-5" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://repeatingislands.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside><aside id="follow_button_widget-3" class="widget widget_follow_button_widget">
		<a class="wordpress-follow-button" href="https://repeatingislands.com" data-blog="6765016" data-lang="en" >Follow Repeating Islands on WordPress.com</a>
		<script type="text/javascript">(function(d){var f = d.getElementsByTagName('SCRIPT')[0], p = d.createElement('SCRIPT');p.type = 'text/javascript';p.async = true;p.src = '//widgets.wp.com/platform.js';f.parentNode.insertBefore(p,f);}(document));</script>

		</aside><aside id="pages-4" class="widget widget_pages"><h1 class="widget-title">Pages</h1>
			<ul>
				<li class="page_item page-item-35847"><a href="https://repeatingislands.com/about-us-2/">About Us</a></li>
<li class="page_item page-item-2688"><a href="https://repeatingislands.com/our-blog/">Our Blog</a></li>
			</ul>

			</aside><aside id="linkcat-1356" class="widget widget_links"><h1 class="widget-title">Blogroll</h1>
	<ul class='xoxo blogroll'>
<li><a href="https://anniepaul.net/" title="Annie Paul&#8217;s sharp, pointed, often witty commentary on current events in Jamaica, the Caribbean, India and the world">Active Voice</a></li>
<li><a href="http://arcthemagazine.com/arc/home/" title="A magazine on contemporary Caribbean art and culture">ARC</a></li>
<li><a href="http://autogiro.cronicaurbana.com/" title="el giro del arte actual en Puerto Rico y el mundo">Autogiro</a></li>
<li><a href="http://www.lehman.cuny.edu/ile.en.ile/" title="Ressources informatives et culturelles du monde insulaire francophone">île en île</a></li>
<li><a href="http://www.caribbeanphilosophicalassociation.org/index.html" title="Website of the Caribbean Philosophical Association">Caribbean Philosophical Association</a></li>
<li><a href="http://caribbeanreviewofbooks.com/" title=" A bimonthly magazine covering Caribbean literature and arts">Caribbean Review of Books</a></li>
<li><a href="http://www.casadelasamericas.org/centroestudios/centroestudioscaribe.php?pagina=caribe" title="Centro de Estudios del Caribe&#8211;Casa de las Americas">Centro de Estudios del Caribe&#8211;Casa de las Americas</a></li>
<li><a href="http://www.gensdelacaraibe.org/index.php" title="Réseau des cultures caribéennes">Gens de la Caraïbe</a></li>
<li><a href="http://www.icp.gobierno.pr/" title="Instituto de Cultura Puertorriqueña [Institute of Puerto Rican Culture] site">Instituto de Cultura Puertorriqueña</a></li>
<li><a href="http://www.isercaribe.org/" title="Driving a new social and scientific praxis">ISER Caribe</a></li>
<li><a href="http://laventana.casa.cult.cu/" title="Portal informativo de la Casa de las Américas">La Ventana</a></li>
<li><a href="http://www.largeup.com/" title="The global platform for Caribbean culture.">LargeUp.com</a></li>
<li><a href="http://www.caribbeanmuseums.com/index.html" title="To allow museums and related organizations and societies in the Caribbean to share experiences and skills, while recognizing the importance of our common heritage.">Museums Association of the Caribbean</a></li>
<li><a href="http://nationalgalleryofjamaica.wordpress.com/" title="A blog featuring news from the National Gallery of Jamaica">National Gallery of Jamaica Blog</a></li>
<li><a href="http://www.potomitan.info/ki_nov/actu.php" title="Site de promotion des cultures et des langues créoles">Potomitan</a></li>
<li><a href="http://www.puertoricanstudies.org/" title="Website of the Puerto Rican Studies Association">Puerto Rican Studies Association</a></li>
<li><a href="http://www.smallaxe.net/sxsalon/opening.php" title="a small axe literary platform">sx salon</a></li>
<li><a href="http://caribbean.commons.gc.cuny.edu/" title="Caribbean Studies information primarily for those in the Northeast U.S.">The Caribbean Commons</a></li>
<li><a href="http://www.jwilonline.org/" title="Online platform of the Journal of West Indian Literature">The Journal of West Indian Literature</a></li>
<li><a href="http://wordpress.org/">WordPress.org</a></li>
<li><a href="http://www.yardedge.net/" title="Exploring the edge of Jamaican culture">YardEdge.net</a></li>

	</ul>
</aside>
<aside id="calendar-4" class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>September 2021</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="2" class="pad">&nbsp;</td><td>1</td><td><a href="https://repeatingislands.com/2021/09/02/" aria-label="Posts published on September 2, 2021">2</a></td><td>3</td><td>4</td><td><a href="https://repeatingislands.com/2021/09/05/" aria-label="Posts published on September 5, 2021">5</a></td>
	</tr>
	<tr>
		<td><a href="https://repeatingislands.com/2021/09/06/" aria-label="Posts published on September 6, 2021">6</a></td><td><a href="https://repeatingislands.com/2021/09/07/" aria-label="Posts published on September 7, 2021">7</a></td><td><a href="https://repeatingislands.com/2021/09/08/" aria-label="Posts published on September 8, 2021">8</a></td><td><a href="https://repeatingislands.com/2021/09/09/" aria-label="Posts published on September 9, 2021">9</a></td><td><a href="https://repeatingislands.com/2021/09/10/" aria-label="Posts published on September 10, 2021">10</a></td><td><a href="https://repeatingislands.com/2021/09/11/" aria-label="Posts published on September 11, 2021">11</a></td><td><a href="https://repeatingislands.com/2021/09/12/" aria-label="Posts published on September 12, 2021">12</a></td>
	</tr>
	<tr>
		<td>13</td><td><a href="https://repeatingislands.com/2021/09/14/" aria-label="Posts published on September 14, 2021">14</a></td><td>15</td><td><a href="https://repeatingislands.com/2021/09/16/" aria-label="Posts published on September 16, 2021">16</a></td><td>17</td><td><a href="https://repeatingislands.com/2021/09/18/" aria-label="Posts published on September 18, 2021">18</a></td><td id="today"><a href="https://repeatingislands.com/2021/09/19/" aria-label="Posts published on September 19, 2021">19</a></td>
	</tr>
	<tr>
		<td>20</td><td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td>
	</tr>
	<tr>
		<td>27</td><td>28</td><td>29</td><td>30</td>
		<td class="pad" colspan="3">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://repeatingislands.com/2021/08/">&laquo; Aug</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></aside><aside id="top-posts-4" class="widget widget_top-posts"><h1 class="widget-title">Top Posts &amp; Pages</h1><ul>				<li>
					<a href="https://repeatingislands.com/2021/09/18/10-of-cubas-best-natural-attractions/" class="bump-view" data-bump-view="tp">10 of Cuba&#039;s Best Natural Attractions</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2021/09/18/cecilia-bengolea-brings-jamaican-dancehall-to-art-basel/" class="bump-view" data-bump-view="tp">Cecilia Bengolea brings Jamaican dancehall to Art Basel</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2010/09/15/snakes-in-st-vincent/" class="bump-view" data-bump-view="tp">Snakes in St. Vincent</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2021/09/18/jennifer-lopez-on-feeling-she-doesnt-belong/" class="bump-view" data-bump-view="tp">Jennifer Lopez on feeling she doesn’t &#039;belong&#039;</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2021/09/18/barbados-pursues-norwegian-model-going-green-at-home-and-drilling-for-oil/" class="bump-view" data-bump-view="tp">Barbados pursues ‘Norwegian model’: going green at home and drilling for oil</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2021/09/19/i-will-never-forget-that-i-could-have-lived-with-people-who-loved-me/" class="bump-view" data-bump-view="tp">I Will Never Forget That I Could Have Lived With People Who Loved Me</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2021/09/16/new-caribbean-writing-anyone-then-pree-this/" class="bump-view" data-bump-view="tp">New Caribbean writing anyone? Then PREE this</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2016/10/03/success-story-for-harlem-mom-turned-filmmaker/" class="bump-view" data-bump-view="tp">Success Story for Harlem Mom Turned Filmmaker</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2021/09/18/art-exhibition-gallardo-budoff-growth-breadth-and-terrain/" class="bump-view" data-bump-view="tp">Art Exhibition—&quot;Gallardo/Budoff: Growth, Breadth, and Terrain”</a>					</li>
								<li>
					<a href="https://repeatingislands.com/2013/06/15/5-movies-on-che-guevara-you-must-watch/" class="bump-view" data-bump-view="tp">5 Movies on Che Guevara You Must Watch</a>					</li>
				</ul></aside><aside id="archives-4" class="widget widget_archive"><h1 class="widget-title">Archives</h1>
			<ul>
					<li><a href='https://repeatingislands.com/2021/09/'>September 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/08/'>August 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/07/'>July 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/06/'>June 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/05/'>May 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/04/'>April 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/03/'>March 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/02/'>February 2021</a></li>
	<li><a href='https://repeatingislands.com/2021/01/'>January 2021</a></li>
	<li><a href='https://repeatingislands.com/2020/12/'>December 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/11/'>November 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/10/'>October 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/09/'>September 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/08/'>August 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/07/'>July 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/06/'>June 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/05/'>May 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/04/'>April 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/03/'>March 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/02/'>February 2020</a></li>
	<li><a href='https://repeatingislands.com/2020/01/'>January 2020</a></li>
	<li><a href='https://repeatingislands.com/2019/12/'>December 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/11/'>November 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/10/'>October 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/09/'>September 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/08/'>August 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/07/'>July 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/06/'>June 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/05/'>May 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/04/'>April 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/03/'>March 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/02/'>February 2019</a></li>
	<li><a href='https://repeatingislands.com/2019/01/'>January 2019</a></li>
	<li><a href='https://repeatingislands.com/2018/12/'>December 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/11/'>November 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/10/'>October 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/09/'>September 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/08/'>August 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/07/'>July 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/06/'>June 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/05/'>May 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/04/'>April 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/03/'>March 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/02/'>February 2018</a></li>
	<li><a href='https://repeatingislands.com/2018/01/'>January 2018</a></li>
	<li><a href='https://repeatingislands.com/2017/12/'>December 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/11/'>November 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/10/'>October 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/09/'>September 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/08/'>August 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/07/'>July 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/06/'>June 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/05/'>May 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/04/'>April 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/03/'>March 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/02/'>February 2017</a></li>
	<li><a href='https://repeatingislands.com/2017/01/'>January 2017</a></li>
	<li><a href='https://repeatingislands.com/2016/12/'>December 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/11/'>November 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/10/'>October 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/09/'>September 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/08/'>August 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/07/'>July 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/06/'>June 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/05/'>May 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/04/'>April 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/03/'>March 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/02/'>February 2016</a></li>
	<li><a href='https://repeatingislands.com/2016/01/'>January 2016</a></li>
	<li><a href='https://repeatingislands.com/2015/12/'>December 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/11/'>November 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/10/'>October 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/09/'>September 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/08/'>August 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/07/'>July 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/06/'>June 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/05/'>May 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/04/'>April 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/03/'>March 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/02/'>February 2015</a></li>
	<li><a href='https://repeatingislands.com/2015/01/'>January 2015</a></li>
	<li><a href='https://repeatingislands.com/2014/12/'>December 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/11/'>November 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/10/'>October 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/09/'>September 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/08/'>August 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/07/'>July 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/06/'>June 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/05/'>May 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/04/'>April 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/03/'>March 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/02/'>February 2014</a></li>
	<li><a href='https://repeatingislands.com/2014/01/'>January 2014</a></li>
	<li><a href='https://repeatingislands.com/2013/12/'>December 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/11/'>November 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/10/'>October 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/09/'>September 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/08/'>August 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/07/'>July 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/06/'>June 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/05/'>May 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/04/'>April 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/03/'>March 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/02/'>February 2013</a></li>
	<li><a href='https://repeatingislands.com/2013/01/'>January 2013</a></li>
	<li><a href='https://repeatingislands.com/2012/12/'>December 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/11/'>November 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/10/'>October 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/09/'>September 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/08/'>August 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/07/'>July 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/06/'>June 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/05/'>May 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/04/'>April 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/03/'>March 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/02/'>February 2012</a></li>
	<li><a href='https://repeatingislands.com/2012/01/'>January 2012</a></li>
	<li><a href='https://repeatingislands.com/2011/12/'>December 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/11/'>November 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/10/'>October 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/09/'>September 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/08/'>August 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/07/'>July 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/06/'>June 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/05/'>May 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/04/'>April 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/03/'>March 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/02/'>February 2011</a></li>
	<li><a href='https://repeatingislands.com/2011/01/'>January 2011</a></li>
	<li><a href='https://repeatingislands.com/2010/12/'>December 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/11/'>November 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/10/'>October 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/09/'>September 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/08/'>August 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/07/'>July 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/06/'>June 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/05/'>May 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/04/'>April 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/03/'>March 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/02/'>February 2010</a></li>
	<li><a href='https://repeatingislands.com/2010/01/'>January 2010</a></li>
	<li><a href='https://repeatingislands.com/2009/12/'>December 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/11/'>November 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/10/'>October 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/09/'>September 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/08/'>August 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/07/'>July 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/06/'>June 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/05/'>May 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/04/'>April 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/03/'>March 2009</a></li>
	<li><a href='https://repeatingislands.com/2009/02/'>February 2009</a></li>
			</ul>

			</aside>		</div><!-- #secondary -->
			</div><!-- .sidebar-content -->
</div><!-- #sidebar -->

	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
				<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202138y' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1610363240h'></script>

	<script>
		// Initialize and attach hovercards to all gravatars
		( function() {
			function init() {
				if ( typeof Gravatar === 'undefined' ) {
					return;
				}

				if ( typeof Gravatar.init !== 'function' ) {
					return;
				}

				Gravatar.profile_cb = function ( hash, id ) {
					WPGroHo.syncProfileData( hash, id );
				};

				Gravatar.my_hash = WPGroHo.my_hash;
				Gravatar.init( 'body', '#wp-admin-bar-my-account' );
			}

			if ( document.readyState !== 'loading' ) {
				init();
			} else {
				document.addEventListener( 'DOMContentLoaded', init );
			}
		} )();
	</script>

		<div style="display:none">
	</div>
<script id='highlander-comments-js-extra'>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/repeatingislands.wordpress.com\/public.api\/connect\/?action=request&domain=repeatingislands.com","logoutURL":"https:\/\/repeatingislands.wordpress.com\/wp-login.php?action=logout&_wpnonce=55fd217af4","homeURL":"https:\/\/repeatingislands.com\/","postID":"169159","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1626677336j'></script>

<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20210915";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20210917";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

			<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/repeatingislands.com\/2021\/09\/19\/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer\/":169159};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2021/09/19/the-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"
				data-lazy="true"
				data-url="https://www.google.com/recaptcha/api.js?hl=en"></div>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/_static/??/wp-content/mu-plugins/carousel/swiper-bundle.css,/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1630955947j&cssminify=yes' type='text/css' media='all' />
<script id='coblocks-lightbox-js-extra'>
var coblocksLigthboxData = {"closeLabel":"Close Gallery","leftLabel":"Previous","rightLabel":"Next"};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"\/wp-content\/mu-plugins\/carousel\/swiper-bundle.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/repeatingislands.com\/wp-admin\/admin-ajax.php","nonce":"385f7bd72d","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/repeatingislands.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Frepeatingislands.com%2F2021%2F09%2F19%2Fthe-rock-that-ended-the-dinosaurs-was-much-more-than-a-dino-killer%2F","blog_id":"6765016","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"stats_query_args":"blog=6765016&v=wpcom&tz=-4&user_id=0&subd=repeatingislands","is_public":"1"};
</script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s0.wp.com/_static/??-eJyNUu1OwzAMfCHSbEPA9gPxKChN3NZtvhYn68bT41UUiQ46fjl27nJ3cuQYhQ4+g8+yJ2nghBriuerpQf686o8F0uWrVOhPCONdWA85Kj2IBIQfsIS7IqItLXqSFgcgyaQCnfLGQlqCZ6QOtQ16ILmrtptqKw3SJDzPhcW2y3W4yZA7cKwRSy3roJIZlR2uRDZ44+wvLA0YWcAPogm6kGjwWwa9tsUwafLiHD/DsaO9VA79SvIRTQuZJLtvSSA/bG0YF+2KP11q1JPo9bAipAwbEbVK0inKkPgkcuLt0N01jpETiZjC+cKZeEb5t9jcgqvB3EmsVQqFwMr5d8yDNfMDkoMsHquNfGdN2YTk/qEhJuuLdoUXA2XRWIVJUqcS+nauTHpzr9vn3WG/2z8dXvpPFs00aA=='></script>
<script type='text/javascript'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-pocket' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-pocket' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-tumblr' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-tumblr' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<iframe src='https://widgets.wp.com/likes/master.html?ver=20210818#ver=20210818&amp;origin=https://repeatingislands.com' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'>
		<div class="likes-text">
			<span>%d</span> bloggers like this:		</div>
		<ul class="wpl-avatars sd-like-gravatars"></ul>
	</div>
	
		<script src="//stats.wp.com/w.js?62" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'6765016','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'6765016','v':'wpcom','tz':'-4','user_id':'0','post':'169159','subd':'repeatingislands'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5U1JMLU8/MkNtblkvY1d6dGdUUH44QWQuaHBWcytGZzBYX2hsV1kuaERSaiYuVnRTNVVGbmwwP1FtSnkwOSVrbWNuX3BdaXBLUm5sbi4/ZnomWzdTdHwyV3RtM25VTEE0Sm50bFozWEt5VWJ5UDU4Nk0rTEd1ejFbamRDdjdrW3RJUn5jaFdjaVZKP0ssY01saixYXzlRWXAzVktxLlhUZ0JEeW1uaWt5fGNFb2hVc1pHJkhYYlVJZ1l3RlRRJXxWL0tPLS1+fkZjMURta1hyXUtYcENHfnhrbENlVkRqVSxtWmRGRTl8ZjV6'}]);
_stq.push([ 'clickTrackerInit', '6765016', '169159' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>